using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Z(?:I[^U]|[^I]).*$";
string input = @"ZISADR
ZIUSADR
ZDDDDR
ZISADR
ZAUSDR
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}