using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)([\p{Arabic}]{3})[^\p{Arabic}]{0,7}([\p{Arabic}]{3})[^\p{Arabic}]{0,7}([\p{Arabic}]{4}).*";
string input = @"٩٠٥٣٣٤٠٠٦٩٠٢";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}