package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)([\p{Arabic}]{3})[^\p{Arabic}]{0,7}([\p{Arabic}]{3})[^\p{Arabic}]{0,7}([\p{Arabic}]{4}).*`)
var str = `٩٠٥٣٣٤٠٠٦٩٠٢`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}