using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{([a-z_]\w*)\}";
string input = @"Original example:
{login}:{password}:{ip}
What about other field names? `e-mail` would be acceptable depending on the DB but it's
probably not a good idea to create field names with special chars.
{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}