# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*) (\w\w\w) (\2)$"
test_str = ("A Nightmare On Elm Street 720p Bluray X264-Pahe In mkv mkv\n"
"Austin Powers International Man Of Mystery 480p Bluray 300mb-Pahe In mkv mkv\n"
"Death_warrant_1990_720p_bluray_x264_750mb-Pahe In mkv mkv\n"
"Die Frau Des Polizisten 720p Bluray X264-Pahe In mkv mkv")
subst = "\\1.\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.