import Foundation
let pattern = #" (\w\w\w) (\1)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A Nightmare On Elm Street 720p Bluray X264-Pahe In mkv mkv
Austin Powers International Man Of Mystery 480p Bluray 300mb-Pahe In mkv mkv
Death_warrant_1990_720p_bluray_x264_750mb-Pahe In mkv mkv
Die Frau Des Polizisten 720p Bluray X264-Pahe In mkv mkv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)