$re = '/<img\b.*?\bsrc=[\'"](?!https?:\/\/img\.[a-z0-9]*\.test\/)([^\'"]*)/mi';
$str = '<img alt=\'\' src=\'http://img.dev.teeeest/images/UID\' />
<img alt=\'\' src=\'https://img.deaaav.test.com/images/UID/\' />
<img alt=\'\' src=\'http://api.com/images/UID\' />
<img alt=\'\' src=\'http://img.deaSassav.test/images/UID\' />
<img alt=\'\' src=\'https://img.dev.test/images/UID\' />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);