#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/(?<address>[A-Za-z0-9\.\/]{1,})\/(?<sectorBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<leitoBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<language>por|en)$" & @CRLF & _
""
Local $sString = "https://totvsfood.ninegrid.com.br/retail/pdv/UWXAZM/NTg2MQ==/MTAx/por" & @CRLF & _
"https://totvsfood.ninegrid.com.br/retail/app/UWXAZ/NDc5Nw==/FSDFSD==/en" & @CRLF & _
"" & @CRLF & _
"https://staging.ninegrid.com.br/retail/app/LERL/MzAzMw==/MTAx/por" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")