import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "uRD.+Accept\\s+\\d{2},\\d{2},\\d{2},rc=\\d+";
        final String string = "03712            13:29:16:328  uWR 724  Accept   00,01,02,00,00,00,00,00,00,32,32,rc=00\n"
	 + "03712            13:29:17:515  uRD 724  Accept   00,01,00,rc=00";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}