import re
regex = re.compile(r"uRD.+Accept\s+\d{2},\d{2},\d{2},rc=\d+")
test_str = ("03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00\n"
"03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")