$re = '/[a-fA-F\d]/m';
$str = 'A3f32
a93s3
q33eg
2Fa32
affff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);