package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^5$`)
var str = `Match ENTIRE LINE of these lines:
1,2,3,4
-1,2,-3,4,-5
1000,100,10,1,0
5
and NONE of these:
2,3,
,,,
-,-
3-2,4-5
-50,up
down,20
apple,banana,pear
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}