$re = '/^(?<url>(https|http):\/\/\w+\/\w+\/)/m';
$str = 'https://xxxx/yyyy/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);