import Foundation
let pattern = #"^((25[0-5]|(2[0-4]|1\d|[1-9])?\d)(\.(?!$)|$)){4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
192.168.0.12
255.255.255.0
256.178.222.345
218.255.1.0
1.1.1.1 e ip 192.168.10.3
0.0.0.0
192.0.9.25
33.1.1.1
123.1.5.4
1.10.100.3
3.
http://192.168.255.111/teste
30.168.1.255.1
127.1
192.168.1.256
-1.2.3.4
1.1.1.1.
3...3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)