package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9\h/\\?:().,'+-]+$`)
var str = `slash/
minus-
questionmark?
twopoint:
openparenthesis(
closeparenthesis)
point.
comma,
simplequote'
plus+
SPACE
azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , ' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfgh\\jklmwxcvbn/ - ? : ( ) . , ' +
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}