re = /^[a-zA-Z0-9\h\/\\?:().,'+-]+$/m
str = 'slash/
minus-
questionmark?
twopoint:
openparenthesis(
closeparenthesis)
point.
comma,
simplequote\'
plus+
SPACE
azertyuiopqsdfghjklmwxcvbn0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfghjklmwxcvbn/ - ? : ( ) . , \' +0123456789AZERTYUIOPQSDFGHJKLMWXCVBN
azertyuiopqsdfgh\\\\jklmwxcvbn/ - ? : ( ) . , \' +
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end