import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[$€]{1}(?P<amount>[\\d,\\.]+(?>\\.\\d{2}){0,})\\b";
final String string = "2 BED / 2 BATH for $120,000.00, what a deal!!!\n"
+ "$120,000.00\n"
+ "€40,000. bla bla\n"
+ "€40.000, bla bla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}