# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\.?\d{1,5}(?:\.\d{1,5})*$"
test_str = ("1\n"
"12\n"
"123\n"
"1234\n"
"12345\n"
"123456\n"
"1.2\n"
".1\n"
".1.2\n"
"1234567890\n"
"1234567890.\n"
"12345.67890\n"
".1234567890\n"
"123.4567.890\n"
".1234567890.\n"
"12345..67890\n"
".1234.567890.\n"
"1.234.567.890\n"
".123.456.7890\n"
".1.2.3.4.5.6.7.8.9.0\n"
".1.2.3.4.5.6.7.8.9.0.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.