const regex = new RegExp('url:\\h"\\K[^"]+(?=/ajax/ads)', 'gm')
const str = `\$.ajax({type: "POST",url: "/dir1/dir2/ajax/ads",data: "view=list",dataType: "html",cache: false,success: function (data) {
}});`;
const subst = `ЗначениеДляЗамены`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);