$re = '~url:\h"\K[^"]+(?=/ajax/ads)~m';
$str = '$.ajax({type: "POST",url: "/dir1/dir2/ajax/ads",data: "view=list",dataType: "html",cache: false,success: function (data) {
}});';
$subst = "ЗначениеДляЗамены";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;