import Foundation
let pattern = #".*(usluga\d+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
btn btn-default usluga_btn usluga1
usluga_btn usluga1
btn usluga_btn usluga1
btn btn-default usluga_btn usluga2
usluga_btn usluga2
btn usluga_btn usluga2
чтобы из 'btn btn-default usluga3_btn'
и из 'btn btn-default usluga_btn usluga3'
вытаскивалось usluga3 без _btn
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)