using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\%(\w+(-|_)?(\w+)?)\%)+";
string input = @"<div class=""%class_name%"">
This is my pet %breed% and it is %age% years old and has a %best-friend% named %friendName%.
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}