re = /^(?:[^_]*_){4}([^_]+)/m
str = 'Bubble_ALLTIERS_30-65+_M_2%Payers100-500_AEO7D_29_1_EN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end