// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^_]*_){4}([^_]+)").unwrap();
let string = "Bubble_ALLTIERS_30-65+_M_2%Payers100-500_AEO7D_29_1_EN";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}