const regex = /Star Wars\s?\d?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Star Wars\\s?\\d?', 'g')
const str = `La película Star Wars
La película Star Wars 4
La película Star Wars 5
La película StarWars ❌`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}