re = /Star Wars\s?\d?/
str = 'La película Star Wars
La película Star Wars 4
La película Star Wars 5
La película StarWars ❌'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end