import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<time>\\d\\d:\\d\\d:\\d\\d.\\d{3})\\s(?P<date>\\d\\d/\\d\\d/\\d\\d)\\s.*?(?P<pr>Pt\\s{3}\\d+(?:\\.\\d+)?\\s[a-z]+)";
final String string = "Something P LR 0.156462 sccm Pt 25.341343 psig something-else\n\n"
+ "12:37:25.790 08/05/20 Something P LR 0.156462 sccm Pt 25.341343 psig something-else\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}