const regex = new RegExp('(?P<time>\\d\\d:\\d\\d:\\d\\d.\\d{3})\\s(?P<date>\\d\\d/\\d\\d/\\d\\d)\\s.*?(?P<pr>Pt\\s{3}\\d+(?:\\.\\d+)?\\s[a-z]+)', 'gm')
const str = `Something P LR 0.156462 sccm Pt 25.341343 psig something-else
12:37:25.790 08/05/20 Something P LR 0.156462 sccm Pt 25.341343 psig something-else
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}