#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\b\w+\b.*(TS).*?(?=RMK)"
Local $sString = "KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122" & @CRLF & _
"KSTS 021853Z VRB04KT 10SM SCT026 VCTS 17/12 A2989 RMK AO2 SLP115 T01670122" & @CRLF & _
"KSTS 021853Z VRB04KT 10SM SCT026 17/12 A2989 RMK AO2 SLP115 T01670122 TS01670122" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")