$re = '/^[a-z]+(?:-?\d)+$/m';
$str = 'shop----------------1
shop-1---------1
shop1
shop2
shop-1
shop-2
shop-1-2
shop-1-2-3
1-2-shop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);