$re = '/(.*)(\/\d+)(.html)/m';
$str = 'https://yun-sp.com/index.php/vod/detail/id/349.html';
$subst = "https://yun-sp.com/index.php/vod/play/id$2/sid/1/nid/1.html";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;