#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?<object>[-\w]+)/([-\w]+)$"
Local $sString = "Abc-def/edg"
Local $sSubst = "$2 - / - $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)