import Foundation
let pattern = #"^(?<object>[-\w]+)/([-\w]+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Abc-def/edg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2 - / - $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)