$re = '/^((?!.*?shows).)*|^((?!.*?Dealt).)*/m';
$str = 'foo shows bar
foo Dealt bar
line without either one
line with both shows Dealt ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);