import Foundation
let pattern = #"("\s+|^[\w\s\w])|(\s+")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"name":" won",addr:" seoul 2 ","age": 2}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)