$re = '/^[#\s]*CI_ENVIRONMENT[=\s]+(?:[a-z]+)$/m';
$str = '#CI_ENVIRONMENT=production
# CI_ENVIRONMENT=development
# CI_ENVIRONMENT = development
#CI_ENVIRONMENT = production';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);