import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\+|00)33[\\s.-]{0,3}(?:\\(0\\)[\\s.-]{0,3})?|0)[1-9](?:(?:[\\s.-]?\\d{2}){4}|\\d{2}(?:[\\s.-]?\\d{3}){2})$";
final String string = "French Phone Number Validation.\n"
+ "Accept several kind of format, more or less usual. And refuse incorrect formats.\n"
+ " - Prefix: 0033 / +33 / (0) / 0\n"
+ " - Number: collapsed / group by 2 / group by 3\n"
+ " - Separator: space / dot / dash\n\n"
+ "~ Accepted ~\n"
+ "0123456789\n"
+ "01 23 45 67 89\n"
+ "01.23.45.67.89\n"
+ "0123 45.67.89\n"
+ "0033 123-456-789\n"
+ "0033(0)123456789\n"
+ "+33-1.23.45.67.89\n"
+ "+33 - 123 456 789\n"
+ "+33(0) 123 456 789\n"
+ "+33 (0)123 45 67 89\n"
+ "+33 (0)1 2345-6789\n"
+ "+33(0) - 123456789\n\n"
+ "~ Rejected ~\n"
+ "012345678\n"
+ "01234567890\n"
+ "0+123456789\n"
+ "(0)123456789\n"
+ "01 23 45 67 89\n\n"
+ "~ Accepted but strange ~\n"
+ "+33.-.123456789\n"
+ "+33.-.(0)-.-123456789\n"
+ "01 23.45-67.89\n";
final String subst = "false";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}