const regex = /example.com\/(?!fr|FR)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('example.com\\\/(?!fr|FR)', 'gm')
const str = `example.com/fr/products/lighting
example.com/fr/products/kitchen
example.com/FR/products
example.com/de/products/lighting
example.com/it
example.com/en/products/outdoor-furniture`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}