re = /^(0|\+98)9[0-9]{9}$/mi
str = '09156987452
09908472853
09153610882365
09158645287
+9814756842
+980915874622
+989908472853
+981283547
9836587498
+986859554
+989158497858
+9812457868
02154091563214587
12409156032145
091596356478
+982654789652
023654d
5588
879 091586424569
+9878546
+9999999999999
+989153610883
0915603551555555555
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end