package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).Section(\d+(?:\.\d+)?).*/Jack/M`)
var str = `#Section250342,Main,First/HS/12345/Jack/M,2000 10.00,#Section250322,Main,First/HS/12345/Aaron/N,2000 17.00,#Section250399,Main,First/HS/12345/Jimmy/N,2000 12.00,#Section251234,Main,First/HS/12345/Jack/M,2000 11.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}