$re = '/(?:Z\d+)(\w)/';
$str = 'Z171PZ7AZ23PZ7819AZ78GZ1AZ99IZ34O';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);