using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*.*?\*\/|\/+[^)]*?$";
string input = @".test {
background-image: url(//www.google.com/image/1.png); // goole // iamge
}
@font-face {
font-display: auto;
font-family: vant-icon; ////// blah// !!!
font-style: normal;
font-weight: 400;
src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)
format(""woff2""),
url(""https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022"")
format(""woff"");
}
/**
Some comment
*/ body {
color: /* some nice
color */ gold;
}";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}