$re = '/\/\*.*?\*\/|\/+[^)]*?$/sm';
$str = '.test {
background-image: url(//www.google.com/image/1.png); // goole // iamge
}
@font-face {
font-display: auto;
font-family: vant-icon; ////// blah// !!!
font-style: normal;
font-weight: 400;
src: url(https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff2?t=1694918397022)
format("woff2"),
url("https://at.alicdn.com/t/c/font_2553510_kfwma2yq1rs.woff?t=1694918397022")
format("woff");
}
/**
Some comment
*/ body {
color: /* some nice
color */ gold;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);