$re = '/(?<token>.{5})\/?/m';
$str = '07/01010
0/0/0/BBBBB
AAAAA/BBBBB/CCCCC
07071';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);