using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bof the\b(*SKIP)(?!)|\bthe\b";
string substitution = @"of the";
string input = @"time of the day word of the day time the day";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}