use strict;
my $str = 'time of the day word of the day time the day';
my $regex = qr/\bof the\b(*SKIP)(?!)|\bthe\b/mp;
my $subst = 'of the';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";