import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:ktm(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*-)?abcd(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*$";
final String string = "abcd-st-ed-qrew\n"
+ "ktm-ewe-abcd-st-ed-qrew\n"
+ "abcd-st-wer-qrew-wabe\n"
+ "ktm-ewe-abcd-st-qrew-qrrt\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}