# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:'|\")\${(\d):.*?}(?:'|\")/$\g<1>$/g;t' <<< "import configparser
configIni = configparser.ConfigParser()
configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')"