$re = '/(?:\'|\")\${(\d):.*?}(?:\'|\")/';
$str = 'import configparser
configIni = configparser.ConfigParser()
configIni.read(\'${1:example.ini}\')configIni.read(\'${2:example2.ini}\')';
$subst = "$\g<1>$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;