import re
regex = re.compile(r"(?:'|\")\${(\d):.*?}(?:'|\")")
test_str = ("import configparser\n"
"configIni = configparser.ConfigParser()\n"
"configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')")
subst = "$\\g<1>$"
result = regex.sub(subst, test_str)
if result:
print(result)